• All nodes with (E) status

    From Nightfox@VERT/DIGDIST to All on Tue Jun 14 10:31:45 2022
    I've been running GTKMonitor since I moved my BBS to Linux, and this morning I noticed GTKMonitor was showing (E) next to all my nodes. The wiki says that means the node will run its daily event (if one is specified) before waiting for another call:
    http://wiki.synchro.net/ref:node_status

    The thing is, I don't have any daily event commands specified for any of my nodes. I'm wondering what might cause all the nodes to go into the E status? I closed and re-started sbbs and then none of my nodes were showing (E) status anymore.

    Nightfox

    ---
    Synchronet Digital Distortion: digitaldistortionbbs.com
  • From Digital Man@VERT to Nightfox on Tue Jun 14 12:15:40 2022
    Re: All nodes with (E) status
    By: Nightfox to All on Tue Jun 14 2022 10:31 am

    I've been running GTKMonitor since I moved my BBS to Linux, and this morning I noticed GTKMonitor was showing (E) next to all my nodes. The wiki says that means the node will run its daily event (if one is specified) before waiting for another call:
    http://wiki.synchro.net/ref:node_status

    The thing is, I don't have any daily event commands specified for any of my nodes.

    That's correct, the 'E' status is set without regard to whether or not any daily events are actually configured for a specific node.

    I'm wondering what might cause all the nodes to go into the E
    status?

    It happens ever night. But the flag is auto-cleared too by sbbs.

    I closed and re-started sbbs and then none of my nodes were showing (E) status anymore.

    Normally, they'll get cleared automatically when the node is connected to by a client (or when an already connected client disconnects). I think what you're describing is normal behavior.
    --
    digital man (rob)

    Synchronet/BBS Terminology Definition #37:
    FTSC = FidoNet Technical Standards Committee
    Norco, CA WX: 77.8F, 53.0% humidity, 7 mph E wind, 0.00 inches rain/24hrs
    ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Nightfox@VERT/DIGDIST to Digital Man on Wed Jun 15 10:03:52 2022
    Re: All nodes with (E) status
    By: Digital Man to Nightfox on Tue Jun 14 2022 12:15 pm

    I've been running GTKMonitor since I moved my BBS to Linux, and this
    morning I noticed GTKMonitor was showing (E) next to all my nodes.
    The wiki says that means the node will run its daily event (if one is
    specified) before waiting for another call:
    http://wiki.synchro.net/ref:node_status


    That's correct, the 'E' status is set without regard to whether or not any daily events are actually configured for a specific node.

    I'm wondering what might cause all the nodes to go into the E
    status?

    It happens ever night. But the flag is auto-cleared too by sbbs.

    I closed and re-started sbbs and then none of my nodes were showing
    (E) status anymore.

    Normally, they'll get cleared automatically when the node is connected to by a client (or when an already connected client disconnects). I think what you're describing is normal behavior.

    This morning I noticed the E status was on all my nodes again. I also noticed my BBS had not downloaded any new messages from the message networks. It also had not run its nightly events. I shut down and re-started sbbs, and it then ran the nightly events that were supposed to run hours ago, and it also ran the binkpoll and fidoin events and got new messages for the message networks.

    So it seems something about my BBS is getting stuck somewhere. Do you know of anything I can check for to determine what might be getting stuck? Recently I had checked to see if Synchronet is writing an event log somewhere, but I didn't see an event log - maybe I just didn't know where to look. I'm wondering what log I might be able to check, if any. Or perhaps there's a DOS command I have in an event that's getting stuck and the window isn't showing?

    Nightfox

    ---
    Synchronet Digital Distortion: digitaldistortionbbs.com
  • From Digital Man@VERT to Nightfox on Wed Jun 15 11:28:27 2022
    Re: All nodes with (E) status
    By: Nightfox to Digital Man on Wed Jun 15 2022 10:03 am

    Re: All nodes with (E) status
    By: Digital Man to Nightfox on Tue Jun 14 2022 12:15 pm

    I've been running GTKMonitor since I moved my BBS to Linux, and this
    morning I noticed GTKMonitor was showing (E) next to all my nodes.
    The wiki says that means the node will run its daily event (if one is
    specified) before waiting for another call:
    http://wiki.synchro.net/ref:node_status


    That's correct, the 'E' status is set without regard to whether or not any daily events are actually configured for a specific node.

    I'm wondering what might cause all the nodes to go into the E
    status?

    It happens ever night. But the flag is auto-cleared too by sbbs.

    I closed and re-started sbbs and then none of my nodes were showing
    (E) status anymore.

    Normally, they'll get cleared automatically when the node is connected to by a client (or when an already connected client disconnects). I think what you're describing is normal behavior.

    This morning I noticed the E status was on all my nodes again. I also noticed my BBS had not downloaded any new messages from the message networks. It also had not run its nightly events. I shut down and re-started sbbs, and it then ran the nightly events that were supposed to run hours ago, and it also ran the binkpoll and fidoin events and got new messages for the message networks.

    So it seems something about my BBS is getting stuck somewhere.

    It sounds like your Event Thread is stuck.

    Do you know
    of anything I can check for to determine what might be getting stuck?

    The event log output.

    Recently I had checked to see if Synchronet is writing an event log somewhere, but I didn't see an event log - maybe I just didn't know where to look. I'm wondering what log I might be able to check, if any.

    The event thread logs to the same place your terminal server is logging, e.g. https://wiki.synchro.net/monitor:syslog

    Or perhaps
    there's a DOS command I have in an event that's getting stuck and the window isn't showing?

    Perhaps. The log should point you to the last executed event before it got "stuck".
    --
    digital man (rob)

    Synchronet "Real Fact" #10:
    The name "DOVE-Net" was suggested by King Drafus (sysop of The Beast's Domain) Norco, CA WX: 77.9F, 58.0% humidity, 0 mph E wind, 0.00 inches rain/24hrs
    ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Nightfox@VERT/DIGDIST to Digital Man on Wed Jun 15 11:57:08 2022
    Re: All nodes with (E) status
    By: Digital Man to Nightfox on Wed Jun 15 2022 11:28 am

    It sounds like your Event Thread is stuck.

    The event thread logs to the same place your terminal server is logging, e.g. https://wiki.synchro.net/monitor:syslog

    Thanks.

    Nightfox

    ---
    Synchronet Digital Distortion: digitaldistortionbbs.com